Ошибка:

После обновления версии 1С на сервере, необходимо обновить клиент, но после установки версии клиента, все равно выскакивает сообщение о том, что версии клиента и сервера не соответствуют.

Причина:

Подключение идёт через веб-модуль. Криво-косое сообщение об ошибке выглядит так, будто версия клиента более ранняя, чем версия сервера. На самом деле, после обновления версии сервера 1с, версию веб-сервера необходимо обновлять отдельно и дополнительно ("переопубликовывать"). После перепубликаципи ошибка исчезает.